# Gaia OS backup or snapshot fails with "There is already another backup process running"

## Product
Security Gateways, Security Management

## Version
R80.30 (EOS), R80.40 (EOS), R81 (EOS), R81.10 (EOS), R81.20, R82, R82.10

## OS
Gaia

## Last Modified
2025-01-16

## Symptoms

- The Gaia Clish "`add backup local`" command fails with this error message:

HostName> add backup local
    Creating backup package. Use the command 'show backup status' to monitor creation progress.
    In order for the backup to be effective you should copy the file outside the machine.

- The Gaia Clish "`show backup status`" command shows one of these messages:

HostName> show backup status
    local backup has failed.
    There is already another backup process running.
    
    or
    
    HostName> show backup status
    Performing  backup
    Step:

- The Expert mode "`backup`" command fails with this error message:

[Expert@HostName]# backup -d
    ...
    BACKUP operation started.
    Failed to create lock file
    The backup operations are locked.
    BACKUP operation failed.Details: There is already another backup process running.
    CBackupUtils::LogBackup() startingThere is already another backup process running.

- The Gaia Clish "`add snapshot`" command fails with this error message:

NMSNAP9999 snapshot: another backup is currently in execution. Please try again in a few moments.

- The Expert mode "`ps auxw`" command does not show any other backup process.

- The `/var/log/messages` file may contain these lines for the time when you ran the backup commands:

ipstcl2: regStrCmp: Match found of the string jPassword at pattern jPassword (0,9)
    ipstcl2: check_special_char: The key jPassword is allowed to have special character at it's value
    xpand[XXX]: backup: backup_alloc_proc().
    xpand[XXX]: backup_set_proc: Started.
    xpand[XXX]: backup: backup_disengage_proc().
    ipstcl2: regStrCmp: Match found of the string msg at pattern msg (0,3)
    ipstcl2: check_special_char: The key msg is allowed to have special character at it's value
    ipstcl2: check_commands_black_list: The userName value contain a black list command
    ipstcl2: Black listed command found

## Cause
When running, the Gaia OS backup needs to acquire a lock on certain files in the operating system. If the backup cannot acquire the lock, it assumes that another backup task is already running.

## Solution
We're here for you

### NOTE
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

## Article Properties
- Access Level: Advanced
- Status: Approved by TAC
- Date Created: 2014-04-24
- Last Modified: 2025-01-16
