sk161294 - Clone Policy Package task in SmartConsole fails with the error "The object name must not contain whitespace characters at the beginning or the end"

Clone Policy Package task in SmartConsole fails with the error "The object name must not contain whitespace characters at the beginning or the end"

Product Multi-Domain Security Management, Security Management
Version R80.10 (EOS), R80.20 (EOS), R80.30 (EOS), R80.40 (EOS), R81 (EOS), R81.10 (EOS), R81.20, R82, R82.10
OS Gaia
Last Modified 2026-07-05

Symptoms

The error message does not contain the name of the problematic rule or object.

Cause

In the Access Control policy, or in the NAT policy, or in the HTTPS Inspection policy, at least one rule name or one section title contains:

Note - SmartConsole does not allow entering these characters (it automatically removes them). This issue was caused by manual editing of the policy rules.

Solution

Part 1 - Upgrade to improve the error message

This problem was fixed. The fix is included in:

This fix changes the error message to contain the problematic rule name and the rule type (Access Control, NAT, HTTPS Inspection).

If you choose not to upgrade, Check Point can supply a Hotfix. Contact Check Point Support to get a Hotfix for this issue.

A Support Engineer will ensure the Hotfix is compatible with your environment before providing the Hotfix.

For faster resolution and verification, please collect CPinfo files from the Security Management Server and Security Gateways involved in the case.

Hotfix installation instructions:
Refer to sk168597 - How to install a Hotfix.

Part 2 - Remove or replace all space characters in the Policy Package

  1. In SmartConsole, on the left navigation panel, click Security Policies.
  2. In the top panel, in the Access Control section, click Policy:
    1. Examine each rule name and each section title.
    2. Remove all space characters in the beginning and in the end.
    3. Remove all new line characters - the text must appear on one line.
  3. In the top panel, in the Access Control section, click NAT:
    1. Examine each rule name and each section title.
    2. Remove all space characters in the beginning and in the end.
    3. Remove all new line characters - the text must appear on one line.
  4. In the top panel, in the Threat Prevention section, click Custom Policy:
    1. Examine each rule name.
    2. Remove all space characters in the beginning and in the end.
    3. Remove all new line characters - the text must appear on one line.
  5. In the top panel, in the HTTPS Inspection section, click Inbound Policy:
    1. Examine each rule name and each section title.
    2. Remove all space characters in the beginning and in the end.
    3. Remove all new line characters - the text must appear on one line.
  6. In the top panel, in the HTTPS Inspection section, click Outbound Policy:
    1. Examine each rule name and each section title.
    2. Remove all space characters in the beginning and in the end.
    3. Remove all new line characters - the text must appear on one line.
  7. In the top panel, in the Shared Policies section, click Mobile Access > Policy:
    1. Examine each rule name and each section title.
    2. Remove all space characters in the beginning and in the end.
    3. Remove all new line characters - the text must appear on one line.
  8. Publish the session.
  9. Clone the Policy Package.

If the issue persists, follow these steps to find the problematic rule that contains the new line character:

  1. Connect to the command line on the Management Server.
  2. Log in to the Expert mode.
  3. On a Multi-Domain Security Management Server, go to the context of the relevant Domain Management Server:
    mdsenv <IP Address of Domain Management Server>
  4. Connect to the PostgreSQL database:
    psql_client cpm postgres
  5. Find the problematic rules:
    select replace(rule_dref.name, chr(10), '<br />') as "Rule name", rule_dref.objid as "Rule UUID", owner_dref.name as "Policy name / Layer name" from dleobjectderef_data rule_dref join rulebaseentitylocalinstance_data rlb_entity on (rlb_entity.entity = rule_dref.objid) join dleobjectderef_data owner_dref on (owner_dref.objid = rlb_entity.owner) where rule_dref.dlesession >= 0 and not rule_dref.deleted and (rule_dref.name like ('%'||chr(10)||'%') OR rule_dref.name like ' %' OR rule_dref.name like '% ');
  6. Quit the PostgreSQL database:
    \q

NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.