sk181946 - "Groups/Users not updated with SID on the MGMT" error message after an upgrade
"Groups/Users not updated with SID on the MGMT" error message after an upgrade
Product
Identity Awareness
Version: R80.40 (EOS), R81 (EOS), R81.10 (EOS), R81.20
Last Modified: 2026-06-01
Symptoms
- Empty SID field in existing AD_Groups and AD_users.
- Updating SIDs fails with the error message: 'null' java.lang.NullPointerException
Cause
In R81, Check Point introduced the usage of SID instead of DN for referring LDAP (usually AD) objects in Identity Awareness.
After upgrading to Check Point R81 or higher, all newly created Active Directory (AD) user and group objects in the database will have the SID (Security Identifier) attribute populated. However, AD users or groups that were added to the database prior to the upgrade have an empty SID field.
NOTE: This SK article is only relevant if the configuration is set to retrieve SIDs. Refer to R81.20 Identity Awareness Administration Guide > Configuring Identity Awareness > Configuring Security Identifier (SID) for LDAP Users
Solution
This problem was fixed. The fix is included in:
- Jumbo Hotfix Accumulator for R81.20 starting from Take 70
- Jumbo Hotfix Accumulator for R81.10 starting from Take 152
- Jumbo Hotfix Accumulator for R81 starting from Take 99
If you choose not to upgrade, Check Point can supply a Hotfix. Contact Check Point Support to get a Hotfix for this issue.
A Support Engineer will make sure the Hotfix is compatible with your environment before providing the Hotfix.
For faster resolution and verification, please collect CPinfo files from the Security Management Server and Security Gateways involved in the case.
Hotfix installation instructions:
Refer to sk168597 - How to install a Hotfix.
Article Properties
Access Level: General
Status: Approved
Date Created: 2024-01-29
Last Modified: 2026-06-01