sk181989 - High core count Security Gateway in Kernel Mode Firewall fails to boot after the Jumbo Hotfix Accumulator upgrade
High core count Security Gateway in Kernel Mode Firewall fails to boot after the Jumbo Hotfix Accumulator upgrade
Product
Check Point Appliances, Cloud Firewall
Version
R81.20
Last Modified
2024-03-18
Symptoms
- Security Gateway boots into Maintenance mode after the Jumbo Hotfix Accumulator upgrade to R81.20 Take 43/ Take 45.
- There is a " CKP: Loading FW-1 IPv4 Instance N: [FAILED]" message in the console logs.
Cause
The Firewall instance size has surpassed the permitted limit set by the Linux Kernel, preventing additional instances from loading.
Solution
Follow these steps to resolve the issue:
Revert Jumbo Hotfix Accumulator R81.20 Take 43/ Take 45 and upgrade to R81.20 Take 53:
- Log in to the Security Gateway to Maintenance mode.
- Edit the file at $FWDIR/boot/boot.conf file in the Visual Editor.
- Adjust the value of KERN_INSTANCE_NUM to a number lower than 40, preferably 30.
- Save the $FWDIR/boot/boot.conf file.
- Reboot the system.
- Uninstall the current Jumbo Hotfix Accumulator.
- Reboot the Security Gateway.
- Edit the file at $FWDIR/boot/boot.conf file in the Visual Editor again.
- Save the $FWDIR/boot/boot.conf file.
- Restore the value of KERN_INSTANCE_NUM to 40.
- Reboot the Security Gateway.
Article Properties
- Access Level: General
- Status: Approved
- Date Created: 2024-02-05
- Last Modified: 2024-03-18