sk181989 - High core count Security Gateway in Kernel Mode Firewall fails to boot after the Jumbo Hotfix Accumulator upgrade

High core count Security Gateway in Kernel Mode Firewall fails to boot after the Jumbo Hotfix Accumulator upgrade

Product

Check Point Appliances, Cloud Firewall

Version

R81.20

Last Modified

2024-03-18

Symptoms

Cause

The Firewall instance size has surpassed the permitted limit set by the Linux Kernel, preventing additional instances from loading.

Solution

Follow these steps to resolve the issue:

Revert Jumbo Hotfix Accumulator R81.20 Take 43/ Take 45 and upgrade to R81.20 Take 53:

  1. Log in to the Security Gateway to Maintenance mode.
  2. Edit the file at $FWDIR/boot/boot.conf file in the Visual Editor.
  3. Adjust the value of KERN_INSTANCE_NUM to a number lower than 40, preferably 30.
  4. Save the $FWDIR/boot/boot.conf file.
  5. Reboot the system.
  6. Uninstall the current Jumbo Hotfix Accumulator.
  7. Reboot the Security Gateway.
  8. Edit the file at $FWDIR/boot/boot.conf file in the Visual Editor again.
  9. Save the $FWDIR/boot/boot.conf file.
  10. Restore the value of KERN_INSTANCE_NUM to 40.
  11. Reboot the Security Gateway.

Article Properties