sk182210 - R81.20 Jumbo Hotfix Accumulator Take 43 (or higher) installation fails for Endpoint Management Server with "Internal error in a hook script"

R81.20 Jumbo Hotfix Accumulator Take 43 (or higher) installation fails for Endpoint Management Server with "Internal error in a hook script"

Product: Endpoint Security - Server
Version: R81.20
OS: Gaia
Last Modified: 2024-09-11

Symptoms

    "Internal error in a hook script: bin/hook_uepm_HOTFIX_R81_20_JUMBO_HF_MAIN. (Return Code: 42). Contact Check Point Technical Services for further assistance.Error: uninstalling of Multi-Domain Security Management R81.20 R81_20_JUMBO_HF_MAIN failed - the machine might be in an unstable state. Contact Check Point Technical Services for further assistance."
    ```

- This error message appears in _/opt/CPuepm-R81.20/logs/upgradeDB_R81.20.elg_ is:
0:  CREATE OR REPLACE FUNCTION validate_tombstone_backup() RETURNS VOID AS $$ BEGIN PERFORM (SELECT 1 FROM ((SELECT * FROM user_attributes LIMIT 0) union all (SELECT * FROM user_attributes_backup LIMIT 0)) as foo); PERFORM (SELECT 1 FROM ((SELECT * FROM recovery_data LIMIT 0) union all (SELECT * FROM recovery_data_backup LIMIT 0)) as foo); PERFORM (SELECT 1 FROM ((SELECT * FROM me_key LIMIT 0) union all (SELECT * FROM me_key_backup LIMIT 0)) as foo); END; $$  LANGUAGE plpgsql VOLATILE; ALTER FUNCTION validate_tombstone_backup() OWNER TO endpoint
Exception occurred on validate_tombstone_backup.sql processing,  failed statement is " select validate_tombstone_backup()", reason is ERROR: UNION types timestamp without time zone and integer cannot be matched
    Where: PL/pgSQL function validate_tombstone_backup() line 1 at PERFORM
Processing validate_tombstone_backup.sql failed.
```

Cause

The order of columns in the tombstone backup tables is different than in the original tables: user_attributes, recovery_data, me_key.

This can happen if the original tables were created without one of the columns before you tried to install the Jumbo Hotfix Accumulator.

Solution

This problem was fixed. The fix is included in:

Note: It is highly recommended to use the latest R81.20 Jumbo Hotfix Accumulator to fix the problem.
  1. Download the archive 151_EPS-54517.zip and extract the upgrade script 151_EPS-54517.sql.
  2. Transfer the extracted file to the server you want to upgrade using an SCP or any file transfer method.
  3. Connect to the CLI of the Endpoint Security Management Server that you want to upgrade.
  4. Switch to the Expert Mode.
  5. Run:

chmod 777 151_EPS-54517.sql 6. Run:

psql_uepm -p 18272 uepm endpoint -f 151_EPS-54517.sql 7. After updating the upgraded script to the database, start the Jumbo Hotfix Accumulator installation again.

NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

Article Properties

Access Level: General
Status: Approved by TAC
Date Created: 2024-04-15
Last Modified: 2024-09-11