sk182507 - SmartConsole fails to connect with this error: "Unable to connect to server. Server is initializing."

SmartConsole fails to connect with this error: "Unable to connect to server. Server is initializing."

Product: Multi-Domain Security Management, Security Management
Version: R81 (EOS), R81.10 (EOS), R81.20, R82
Last Modified: 2026-01-21

Symptoms

Cause

When the Compliance blade is enabled:

  1. The "interpreter" process fails to calculate the next scheduled scan date.
  2. As a result, the FWM process may crash.

Solution

This problem was fixed. The fix is included in:

If after installing the fix you see that additional FWM/interpreter cores, or you choose not to install the new Jumbo Hotfix, it is recommended to set the following configuration.

Workaround 1

If you choose not to upgrade, use this workaround to edit the $MDS_FWDIR/conf/grc.conf file:

  1. Connect to the command line on the management server.

  2. Log in to the Expert mode.

  3. Back up the current file:

    cp -pv $MDS_FWDIR/conf/grc.conf{,_BKP}

  4. Edit the current file:

    vi $MDS_FWDIR/conf/grc.conf

  5. Remove this line:

    interpreterSchedPeriod=86400

  6. Add these lines at the bottom of the file:

    interpreterSchedPeriodDay=7

    interpreterSchedPeriodHour=23

    interpreterSchedPeriodMin=59

    interpreterSchedPeriodSec=59

By default, this schedules the Compliance blade to run every day at 23:59:59.

  1. Save the changes and exit the Vi editor.
  2. Stop the FWM process:
    • Security Management Server:

      cpwd_admin stop -name FWM -path "$FWDIR/bin/fwm" -command "fw kill fwm"

    • Domain Management Server on a Multi-Domain Security Management Server:

      mdsstop_customer <IP Address of Domain Management Server>

  3. Start the FWM process:
    • Security Management Server:

      cpwd_admin start -name FWM -path "$FWDIR/bin/fwm" -command "fwm"

    • Domain Management Server on a Multi-Domain Security Management Server:

      mdsstart_customer <IP Address of Domain Management Server>

Workaround 2

In case additional interpreter core files are seen, follow these steps:

For Multi-Domain Security Management Server:

  1. mdsenv <CMA NAME>
  2. mcd conf
  3. mv grc_notifications.dat grc_notifications.dat_old
  4. mv grc_notifications2.dat grc_notifications2.dat_old
  5. mdsstop_customer <CMA NAME> ; mdsstart_customer <CMA NAME>

For Security Management Server:

  1. cd $FWDIR/conf
  2. mv grc_notifications.dat grc_notifications.dat_old
  3. mv grc_notifications2.dat grc_notifications2.dat_old
  4. cpstop ; cpstart

NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

Article Properties

Access Level: General
Status: Approved by TAC
Date Created: 2024-07-15
Last Modified: 2026-01-21