sk182507 - SmartConsole fails to connect with this error: "Unable to connect to server. Server is initializing."
SmartConsole fails to connect with this error: "Unable to connect to server. Server is initializing."
Product: Multi-Domain Security Management, Security Management
Version: R81 (EOS), R81.10 (EOS), R81.20, R82
Last Modified: 2026-01-21
Symptoms
- SmartConsole fails to connect with this error: " Unable to connect to server. Server is initializing."
- Output of the "ps axw" command on the Management Server shows the "interpreter" processes in the state "zombie".
Cause
When the Compliance blade is enabled:
- The "interpreter" process fails to calculate the next scheduled scan date.
- As a result, the FWM process may crash.
Solution
This problem was fixed. The fix is included in:
- Jumbo Hotfix Accumulator for R82 starting from Take 10
- Jumbo Hotfix Accumulator for R81.20 starting from Take 76
- Jumbo Hotfix Accumulator for R81.10 starting from Take 165
- Jumbo Hotfix Accumulator for R81 starting from Take 106
If after installing the fix you see that additional FWM/interpreter cores, or you choose not to install the new Jumbo Hotfix, it is recommended to set the following configuration.
Workaround 1
If you choose not to upgrade, use this workaround to edit the $MDS_FWDIR/conf/grc.conf file:
Connect to the command line on the management server.
Log in to the Expert mode.
Back up the current file:
cp -pv $MDS_FWDIR/conf/grc.conf{,_BKP}Edit the current file:
vi $MDS_FWDIR/conf/grc.confRemove this line:
interpreterSchedPeriod=86400Add these lines at the bottom of the file:
interpreterSchedPeriodDay=7interpreterSchedPeriodHour=23interpreterSchedPeriodMin=59interpreterSchedPeriodSec=59
By default, this schedules the Compliance blade to run every day at 23:59:59.
- interpreterSchedPeriodDay is the day of the week.
0=Sunday, 1=Monday, 2=Tuesday, 3=Wednesday, 4=Thursday, 5=Friday, 6=Saturday, 7=every day.- interpreterSchedPeriodHour is the hour of the day which can be between 0-23.
- interpreterSchedPeriodMin and interpreterSchedPeriodSec can be between 0-59.
- Save the changes and exit the Vi editor.
- Stop the FWM process:
Security Management Server:
cpwd_admin stop -name FWM -path "$FWDIR/bin/fwm" -command "fw kill fwm"Domain Management Server on a Multi-Domain Security Management Server:
mdsstop_customer <IP Address of Domain Management Server>
- Start the FWM process:
Security Management Server:
cpwd_admin start -name FWM -path "$FWDIR/bin/fwm" -command "fwm"Domain Management Server on a Multi-Domain Security Management Server:
mdsstart_customer <IP Address of Domain Management Server>
Workaround 2
In case additional interpreter core files are seen, follow these steps:
For Multi-Domain Security Management Server:
mdsenv <CMA NAME>mcd confmv grc_notifications.dat grc_notifications.dat_oldmv grc_notifications2.dat grc_notifications2.dat_oldmdsstop_customer <CMA NAME> ; mdsstart_customer <CMA NAME>
For Security Management Server:
cd $FWDIR/confmv grc_notifications.dat grc_notifications.dat_oldmv grc_notifications2.dat grc_notifications2.dat_oldcpstop ; cpstart
NOTE
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.
Article Properties
Access Level: General
Status: Approved by TAC
Date Created: 2024-07-15
Last Modified: 2026-01-21