sk182524 - "vsx-run-operation" fails on the Multi-Domain Security Management Server
"vsx-run-operation" fails on the Multi-Domain Security Management Server
Product: Multi-Domain Security Management
Version: R81.10 (EOS), R81.20, R82
OS: Gaia
Platform: Open Server, VMWare ESX
Last Modified: 2025-08-04
Symptoms
- "
vsx-run-operation" fails on the Multi-Domain Security Management Server with this error:
"VSX upgrade operation" failed (100%)
...
status: "failed"
...
fault-message: "Please verify connectivity with Domain Management Server, authentication credentials and that this machine is defined as a GUI client."
Executed command failed. Changes are discarded.
```
## Cause
There is a mismatch between the management level (CMA vs. MDS) at which the authentication is attempted and the level for which the session token is valid.
1. "`vsx_util`" receives a session token from the Management API and tries to attach itself to the existing SmartConsole session instead of starting a new one.
2. The Management API does not provide the CMA IP address to "`vsx_util`".
3. As a result, "`vsx_util`" defaults to the MDS (Multi-Domain Server) level for authentication. However, the session token it uses is specific to a CMA, not the MDS. This mismatch in authentication levels causes the operation to fail.
## Solution
This problem was fixed. The fix is included in:
- [Jumbo Hotfix Accumulator for R82](https://sc1.checkpoint.com/documents/Jumbo_HFA/R82/Default.htm) starting from Take 36
- [Jumbo Hotfix Accumulator for R81.20](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.20/Default.htm) starting from Take 111
- [Jumbo Hotfix Accumulator for R81.10](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.10/Default.htm) starting from Take 177
If you choose not to upgrade, Check Point can supply a **Hotfix**. [Contact Check Point Support](https://www.checkpoint.com/support-services/contact-support/) to get a Hotfix for this issue.
A Support Engineer will make sure the Hotfix is compatible with your environment before providing the Hotfix.
For faster resolution and verification, please collect [CPinfo files](http://supportcontent.checkpoint.com/solutions?id=sk92739) from the Security Management Server and Security Gateways involved in the case.
**Hotfix installation instructions:**
Refer to [sk168597 - How to install a Hotfix](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk168597).
#### NOTE
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.
## Article Properties
**Access Level**: General
**Status**: Approved by TAC
**Date Created**: 2024-07-21
**Last Modified**: 2025-08-04