# cpd daemon consistently exits with a segfault error and generates a core dump

**Product:** Security Management  
**Version:** R81.10 (EOS), R81.20, R82  
**OS:** Gaia  
**Last Modified:** 2025-06-15

## Symptoms

- cpd daemon restarts with a segfault error in the _/var/log/messages file_.

Sample snippet:

> `kernel:cpd[11964]: segfault at 0 ip 00000000f65aa0d6 sp 00000000ffccd844 error 4 in libc-2.17.so[f6522000+1db000]`

- The process core dump file is generated in the _/var/log/dump/usermode/_ directory after it exits.

## Solution

This problem was fixed. The fix is included in:

- [Jumbo Hotfix Accumulator for R82](https://sc1.checkpoint.com/documents/Jumbo_HFA/R82/Default.htm) starting from Take 25  
- [Jumbo Hotfix Accumulator for R81.20](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.20/Default.htm) starting from Take 99  
- [Jumbo Hotfix Accumulator for R81.10](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.10/Default.htm) starting from Take 173

If you choose not to upgrade, Check Point can supply a **Hotfix**. [Contact Check Point Support](https://www.checkpoint.com/support-services/contact-support/) to get a Hotfix for this issue.

A Support Engineer will make sure the Hotfix is compatible with your environment before providing the Hotfix.

For faster resolution and verification, please collect [CPinfo files](http://supportcontent.checkpoint.com/solutions?id=sk92739) from the Security Management Server and Security Gateways involved in the case.

**Hotfix installation instructions:**

Refer to [sk168597 - How to install a Hotfix](https://supportcenter.checkpoint.com/supportcenter/portal?eventSubmit_doGoviewsolutiondetails=&solutionid=sk168597).

#### NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

## Article Properties

**Access Level:** General  
**Status:** Approved by TAC  
**Date Created:** 2024-11-12  
**Last Modified:** 2025-06-15
