sk183293 - CVPND process fails to start on a newly created Virtual System

CVPND process fails to start on a newly created Virtual System

Symptoms

[Expert@HostName]# cpwd_admin list | grep CVPND

CVPND      3            0      T     1        [23:45:18] 26/3/2025   N     cvpnd /opt/CPcvpn-R81.20/CTX/CTX00003/log/cvpnd.elg /opt/CPcvpn-R81.20/CTX/CTX00003/conf/cvpnd.C
[DATETIME] Exception: SetDataReader::getField: Could not obtain the requested field - field name is:  snxIpAddressToConnectTo - CVPND aborting

Cause

The snxIpAddressToConnectTo parameter is missing from the $CVPNDIR/conf/cvpnd.C file on the new Virtual System, preventing the CVPND from starting.

This parameter was introduced starting from these versions (Ref: PMTR-95099)

Solution

This problem was fixed. The fix is included in:

If you choose not to upgrade, follow these steps:

Run this procedure on the applicable Virtual System to manually add the missing snxIpAddressToConnectTo parameter:

  1. Connect to the command line on the VSX Security Gateway / each VSX Cluster Member.

  2. Log in to the Expert mode and switch to the affected Virtual System environment. # vsenv <VSID>

  3. Back up the current cvpnd.C file.

[Expert@HostName:VSID]# cp -v $CVPNDIR/conf/cvpnd.C{,_BACKUP}
  1. Add the missing snxIpAddressToConnectTo parameter:
[Expert@HostName:VSID]# cvpnd_settings $CVPNDIR/conf/cvpnd.C add snxIpAddressToConnectTo "" nobackup

Example output:

Successfully created snxIpAddressToConnectTo with an empty value.

If you are in a cluster environment - you must make the same changes on each member.

You must restart the services by running cvpnrestart for the changes to take effect.

  1. Restart the Mobile Access services to apply the changes:
[Expert@HostName:VSID]# cvpnrestart
  1. Make sure that the CVPND is running properly:
[Expert@HostName:VSID]# cpwd_admin list | grep CVPND

NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

Article Properties

Access Level: General
Status: Approved by TAC
Date Created: 2025-03-27
Last Modified: 2026-05-26