# CVPND process fails to start on a newly created Virtual System

## Symptoms

- The CVPND process does not start on a newly created Virtual System, and the Mobile Access portal is down.

- The output of command "cpwd_admin list" indicates that the CVPND process is terminated, for example:

```
[Expert@HostName]# cpwd_admin list | grep CVPND

CVPND      3            0      T     1        [23:45:18] 26/3/2025   N     cvpnd /opt/CPcvpn-R81.20/CTX/CTX00003/log/cvpnd.elg /opt/CPcvpn-R81.20/CTX/CTX00003/conf/cvpnd.C
```

- Attempting to access the Mobile Access Portal results in a "ERR_CONNECTION_RESET" error in the browser.

- Attempting to start or restart the Mobile Access services with the commands "`cvpnstart`" or "`cvpnrestart`", this error appears:
  Mobile Access: Failed to start cvpnd daemon.
  Look under /opt/CPcvpn-R81.20/CTX/CTX00006/log/cvpnd.elg for more info.
  Mobile Access: Failed to start cvpn service.

- The _$CVPNDIR/log/cvpnd.elg_ file logs this error:

```
[DATETIME] Exception: SetDataReader::getField: Could not obtain the requested field - field name is:  snxIpAddressToConnectTo - CVPND aborting
```

## Cause

The _snxIpAddressToConnectTo_ parameter is missing from the _$CVPNDIR/conf/cvpnd.C_ file on the new Virtual System, preventing the CVPND from starting.

This parameter was introduced starting from these versions (Ref: PMTR-95099)

- [Jumbo Hotfix Accumulator for R81.20](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.20/Default.htm) starting from Take 70
- [Jumbo Hotfix Accumulator for R81.10](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.10/Default.htm) starting from Take 152
- [Jumbo Hotfix Accumulator for R81](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81/Default.htm) starting from Take 99

## Solution

This problem was fixed. The fix is included in:

- [Jumbo Hotfix Accumulator for R82](https://sc1.checkpoint.com/documents/Jumbo_HFA/R82/Default.htm) starting from Take 103
- [Jumbo Hotfix Accumulator for R82.10](https://sc1.checkpoint.com/documents/Jumbo_HFA/R82.10/Default.htm) starting from Take 6

If you choose not to upgrade, follow these steps:

Run this procedure on the applicable Virtual System to manually add the missing `snxIpAddressToConnectTo` parameter:

1. Connect to the command line on the VSX Security Gateway / each VSX Cluster Member.

2. Log in to the Expert mode and switch to the affected Virtual System environment. `# vsenv <VSID>`

3. Back up the current `cvpnd.C` file.

```
[Expert@HostName:VSID]# cp -v $CVPNDIR/conf/cvpnd.C{,_BACKUP}
```

4. Add the missing `snxIpAddressToConnectTo` parameter:

```
[Expert@HostName:VSID]# cvpnd_settings $CVPNDIR/conf/cvpnd.C add snxIpAddressToConnectTo "" nobackup
```

**Example output:**

```
Successfully created snxIpAddressToConnectTo with an empty value.
```

`If you are in a cluster environment - you must make the same changes on each member.`

`You must restart the services by running cvpnrestart for the changes to take effect.`

5. Restart the Mobile Access services to apply the changes:

```
[Expert@HostName:VSID]# cvpnrestart
```

6. Make sure that the `CVPND` is running properly:

```
[Expert@HostName:VSID]# cpwd_admin list | grep CVPND
```

#### NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

## Article Properties

Access Level: General  
Status: Approved by TAC  
Date Created: 2025-03-27  
Last Modified: 2026-05-26
