sk183550 - Site-to-Site VPN fails with Third-Party Gateway after an upgrade

Site-to-Site VPN fails with Third-Party Gateway after an upgrade

Symptoms

[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::parseAndDecodeMessage: Failed to decode reply msg.
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::processMessage: error detected, Abort.
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::doHandleMessage: error encountered while processing message: -4
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::doHandleMessage: critical error occurred, status is doomed.
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::setStatus: Changing status from: initial to: doomed (final)..
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::continueHandleMessage: entering with status = 8
[iked12 PID]@Hostname[DATE TIME][ikev2] ikeAuthExchange_r::postMessageProcessed: entering. eap state: 0.
[iked12 PID]@Hostname[DATE TIME][ikev2] ikeAuthExchange_r::postMessageProcessed: sending error notification to peer.
[iked12 PID]@Hostname[DATE TIME][ikev2] ikeAuthExchange_r::postMessageProcessed: Exchange has failed and there is no concrete notification. sending Invalid Syntax.
[iked12 PID]@Hostname[DATE TIME][ikev2] NotifyPayload::NotifyPayload: NULL notify data passed
...
[iked12 PID]@Hostname[DATE TIME][CPLOG] CCplogUtils::FillVarArg: str: Auth exchange: Sending notification to peer: Invalid syntax

Cause

A strict validation check was added to the HMAC function. This change affects interoperability with certain third-party VPN devices, causing the IKE authentication process to fail.

Solution

This problem was fixed. The fix is included starting from:

Check Point recommends to always upgrade to the Recommended version ( Security Gateway / VSX / Security Management Server / Multi-Domain Security Management Server / SmartConsole).

If you choose not to upgrade, contact Check Point Support to get a Hotfix for your version.

A Support Engineer will make sure the Hotfix is compatible with your environment before providing it.

For faster resolution and verification, collect these files:

  1. CPinfo file from the Management Server involved in the case.
  2. CPinfo file from the Security Gateway / each Cluster Member involved in the case.

Hotfix installation instructions:

Refer to sk168597 - How to install a Hotfix.

NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.