# Site-to-Site VPN fails with Third-Party Gateway after an upgrade

## Symptoms

- VPN tunnels to third-party peers fail during IKE authentication, after an upgrade to Jumbo hotfix accumulator.
- When the VPN tunnel is initiated by the Security Gateway, the authentication packet fails on the peer gateway, and at the Security Gateway you see that timeout is reached.
- Running IKE debug on the Security Gateway you can see similar logs on the _$FWDIR/log/ike.elg_ file:

```
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::parseAndDecodeMessage: Failed to decode reply msg.
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::processMessage: error detected, Abort.
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::doHandleMessage: error encountered while processing message: -4
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::doHandleMessage: critical error occurred, status is doomed.
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::setStatus: Changing status from: initial to: doomed (final)..
[iked12 PID]@Hostname[DATE TIME][ikev2] Exchange::continueHandleMessage: entering with status = 8
[iked12 PID]@Hostname[DATE TIME][ikev2] ikeAuthExchange_r::postMessageProcessed: entering. eap state: 0.
[iked12 PID]@Hostname[DATE TIME][ikev2] ikeAuthExchange_r::postMessageProcessed: sending error notification to peer.
[iked12 PID]@Hostname[DATE TIME][ikev2] ikeAuthExchange_r::postMessageProcessed: Exchange has failed and there is no concrete notification. sending Invalid Syntax.
[iked12 PID]@Hostname[DATE TIME][ikev2] NotifyPayload::NotifyPayload: NULL notify data passed
...
[iked12 PID]@Hostname[DATE TIME][CPLOG] CCplogUtils::FillVarArg: str: Auth exchange: Sending notification to peer: Invalid syntax
```

## Cause

A strict validation check was added to the HMAC function. This change affects interoperability with certain third-party VPN devices, causing the IKE authentication process to fail.

## Solution

This problem was fixed. The fix is included starting from:

- [Jumbo Hotfix Accumulator for R82](https://sc1.checkpoint.com/documents/Jumbo_HFA/R82/Default.htm) starting from Take 25
- [Jumbo Hotfix Accumulator for R81.20](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.20/Default.htm) starting from Take 103
- [Jumbo Hotfix Accumulator for R81.10](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.10/Default.htm) starting from Take 177

Check Point recommends to always upgrade to the [Recommended version](https://support.checkpoint.com/results/sk/sk95746) ( [Security Gateway](https://support.checkpoint.com/product/73) / [VSX](https://support.checkpoint.com/product/359) / [Security Management Server](https://support.checkpoint.com/product/184) / [Multi-Domain Security Management Server](https://support.checkpoint.com/product/166) / [SmartConsole](https://support.checkpoint.com/product/191)).

If you choose not to upgrade, [contact Check Point Support](https://www.checkpoint.com/support-services/contact-support/) to get a Hotfix for your version.

A Support Engineer will make sure the Hotfix is compatible with your environment before providing it.

For faster resolution and verification, collect these files:

1. [CPinfo](https://support.checkpoint.com/results/sk/sk92739) file from the Management Server involved in the case.
2. [CPinfo](https://support.checkpoint.com/results/sk/sk92739) file from the Security Gateway / each Cluster Member involved in the case.

**Hotfix installation instructions:**

Refer to [sk168597 - How to install a Hotfix](https://support.checkpoint.com/results/sk/sk168597).

#### NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.
