sk183752 - QoS Software Blade fails to start with error: "QoS is not responding. Verify that QoS is installed on the gateway"
QoS Software Blade fails to start with error: "QoS is not responding. Verify that QoS is installed on the gateway"
Product: QoS
Version: R81.10 (EOS), R81.20, R82
OS: Gaia
Last Modified: 2026-02-18
Symptoms
- The QoS Software Blade does not start and displays the error:
'QoS' is not responding. Verify that 'QoS' is installed on the gateway.
- SmartConsole logs show:
QoS service was stopped.
- This error appears while you install the QoS policy:
Error - Make sure the QoS service is started" while installing QoS policy.
- When you manually restart the Blade with the
etmstartcommand, this error appears:
[ERROR] etm_register: Failed to send ETMDRV_HOOK ioctl to all devices
[ERROR] etm_register: Failed to send ETMDRV_TIMERS_STATE 1 ioctl to all devices
[ERROR] etmreg: Operation failed: No such file or directory
QoS: 'fgate ctl etmreg on' Failed"
- Rebooting the Security Gateway resolves the issue temporarily.
Cause
Solution
This problem was fixed. The fix is included in:
- Jumbo Hotfix Accumulator for R82 starting from Take 73
- Jumbo Hotfix Accumulator for R81.20 starting from Take 122
- Jumbo Hotfix Accumulator for R81.10 starting from Take 183
If you choose not to upgrade, Check Point can supply a Hotfix. Contact Check Point Support to get a Hotfix for this issue.
A Support Engineer will make sure the Hotfix is compatible with your environment before providing the Hotfix.
For faster resolution and verification, please collect CPinfo files from the Security Management Server and Security Gateways involved in the case.
Hotfix installation instructions:
Refer to sk168597 - How to install a Hotfix.
NOTE
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.
Article Properties
Access Level: General
Status: Approved by TAC
Date Created: 2025-09-04
Last Modified: 2026-02-18