sk183783 - SmartConsole does not display logs from the Multi-Domain Server and Multi-Domain Log Modules after upgrade to R82
SmartConsole does not display logs from the Multi-Domain Server and Multi-Domain Log Modules after upgrade to R82
Product: Multi-Domain Security Management
Version: R82
Last Modified: 2026-06-01
Symptoms
- SmartConsole does not display logs from the Multi-Domain Server and Multi-Domain Log Modules after upgrade to R82.
- Solr core dumps are generated in this directory:
/var/log/dump/usermode
$INDEXERDIR/log_indexer.elgfile shows these messages:
[4102028096][14 Aug 8:48:17] RFLIndexDoer::sendToSolr: I'm sleep
[4102028096][14 Aug 8:48:17] RFLIndexDoer::sendToSolr: SOLR error_type is - 1
```
- `$RTDIR/log/RFL.log` file shows this message:
`Failed to connect to https://<IP>:8211`
## Cause
Solr indexing engine stops working due to insufficient Java heap space.
Core dump includes:
`0SECTION TITLE subcomponent dump routine`
`NULL ===============================`
`1TICHARSET ANSI_X3.4-1968`
`1TISIGINFO Dump Event "systhrow" (00040000) Detail "java/lang/OutOfMemoryError" "Java heap space" received`
`1TIDATETIMEUTC Date: [date] at [time] (UTC)`
`1TIDATETIME Date: [date] at [time]`
## Solution
This problem was fixed. The fix is included in:
- [Jumbo Hotfix Accumulator for R82](https://sc1.checkpoint.com/documents/Jumbo_HFA/R82/Default.htm) starting from Take 39
If you choose not to upgrade, as a workaround, increase the maximum allowed heap size for the `Solr` process:
1. Check the current heap size setting. Run:
`cat $MDS_FWDIR/conf/cpmServerSettings.props | grep -i RFL_SOLR_MAX_HEAP=`
2. Double the current heap size using the override script. Run:
`cd $MDS_FWDIR/scripts/`
`./override_server_setting.sh -p RFL_SOLR_MAX_HEAP <new_value>`
For example, if the current value is 2048, change it to 4096:
`./override_server_setting.sh -p RFL_SOLR_MAX_HEAP 4096`
3. Restart the Multi-Domain Server services to apply the changes. Run:
`mdsstop;mdsstart`
Note: If issue is not fixed after increasing to 4096 you can increase again the value (to 8192 in that case).
#### NOTE
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.
## Article Properties
**Access Level**: General
**Status**: Approved by TAC
**Date Created**: 2025-08-19
**Last Modified**: 2026-06-01