sk184554 - Security Gateway stops responding with "BUG: soft lockup" in serial console

Security Gateway stops responding with "BUG: soft lockup" in serial console

Product: Check Point Appliances, Security Gateways
Version: R81.20
OS: Gaia
Last Modified: 2026-04-28

Symptoms

[DATE TIME] FW-name snmpd: Error: Timeout waiting for response from database server.
[DATE TIME] FW-name snmpd: Error: Timeout waiting for response from database server.
[DATE TIME] FW-name kernel:NMI watchdog: BUG: soft lockup - CPU#78 stuck for 22s! [fwk0_1:18167]

Cause

Memory fragmentation occurs during huge page allocation, managed by the operating system. This process can lead to CPU soft lockup under heavy load.

Solution

This problem was fixed. The fix is included starting from:

Check Point recommends to always upgrade to the Recommended version ( Security Gateway / VSX / Security Management Server / Multi-Domain Security Management Server / SmartConsole).

If you choose not to upgrade, contact Check Point Support to get a Hotfix for your version.

A Support Engineer will make sure the Hotfix is compatible with your environment before providing it.

For faster resolution and verification, collect these files:

  1. CPinfo file from the Management Server involved in the case.
  2. CPinfo file from the Security Gateway / each Cluster Member involved in the case.

Hotfix installation instructions: Refer to sk168597 - How to install a Hotfix.

NOTE

This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.

Article Properties

Access Level: General
Status: Approved by TAC
Date Created: 2026-01-12
Last Modified: 2026-04-28