# CPView History displays irregular time intervals and large gaps in data

**Product**: Security Gateways  
**Version**: R81.20, R82  
**Last Modified**: 2026-05-26

## Symptoms
- While viewing the `CPView History` via the "`cpview -t`" command, the data is not shown at the expected 1 minute intervals. Instead, the timestamps show significant, irregular gaps (for example, jumping from `12:25:00 directly to 13:00:01`).
- Disabling and re-enabling `CPView History` mode does not resolve the issue and restarting `cpviewd` process doesn't help on it too.
- In `$CPDIR/log/cpview_controller.log`, the following error appears, indicating that a syntax error occurred while processing the SQL command.

```
ts=2025-10-22T08:05:03.763Z caller=state.go:110 level=info msg="StateMachine::FireEvent: Done: State: ClearOldRecords"

ts=2025-10-22T08:05:03.763Z caller=state.go:110 level=info msg="StateMachine::FireEvent: Done: State: FlushInitialData"

ts=2025-10-22T08:05:03.763Z caller=state.go:110 level=info msg="StateMachine::FireEvent: Done: State: BeginTransaction"

ts=2025-10-22T08:05:06.812Z caller=sqlite_job.go:288 level=error msg="runSqliteJob: Got panic SqliteDatabase::exec: After 3 attempts (Query: INSERT INTO cpview_ref_table VALUES((SELECT MAX(seq)+1 FROM cpview_ref_table),'DHCP Check Feature Isn't Supported Or Disabled');, Error: near \"t\": syntax error)"

ts=2025-10-22T08:05:06.813Z caller=sqlite.go:72 level=info msg="Data rollback"

ts=2025-10-22T08:05:06.814Z caller=manager.go:111 level=info msg="Done (sqlite)"
```

## Cause
The SQL query fails because an apostrophe (') in the value "`Isn't`". Apostrophe (single quote) is interpreted as a string delimiter. So, when the parser sees `name = 'Isn't'`, the string gets terminated early. The rest of the intended value (`t'`) is left hanging as invalid syntax preventing the `CPView History` data from being written.

## Solution
This problem was fixed. The fix is included starting from:
- [Check Point Quantum R82.10](https://support.checkpoint.com/results/sk/sk183506)
- [Jumbo Hotfix Accumulator for R82](https://sc1.checkpoint.com/documents/Jumbo_HFA/R82/Default.htm) starting from Take 103
- [Jumbo Hotfix Accumulator for R81.20](https://sc1.checkpoint.com/documents/Jumbo_HFA/R81.20/Default.htm) starting from Take 126

Check Point recommends always upgrading to the [Recommended version](https://support.checkpoint.com/results/sk/sk95746) ( [Security Gateway](https://support.checkpoint.com/product/73) / [VSX](https://support.checkpoint.com/product/359) / [Security Management Server](https://support.checkpoint.com/product/184) / [Multi-Domain Security Management Server](https://support.checkpoint.com/product/166) / [SmartConsole](https://support.checkpoint.com/product/191)).

If you choose not to upgrade, [contact Check Point Support](https://www.checkpoint.com/support-services/contact-support/) to get a Hotfix for your version. A Support Engineer will make sure the Hotfix is compatible with your environment before providing it.

For faster resolution and verification, collect these files:
1. [CPinfo](https://support.checkpoint.com/results/sk/sk92739) file from the Management Server involved in the case.
2. [CPinfo](https://support.checkpoint.com/results/sk/sk92739) file from the Security Gateway / each Cluster Member involved in the case.

**Hotfix installation instructions:**
Refer to [sk168597 - How to install a Hotfix](https://support.checkpoint.com/results/sk/sk168597).

#### NOTE
This solution has been verified for the specific scenario, described by the combination of Product, Version, and Symptoms. It may not work in other scenarios.

## Article Properties  
**Access Level**: General  
**Status**: Approved by TAC  
**Date Created**: 2026-04-11  
**Last Modified**: 2026-05-26
