sk91343 - FWD process consumes CPU/memory at high level on Multi-Domain Management Server when LEA clients are connected to it

FWD process consumes CPU/memory at high level on Multi-Domain Management Server when LEA clients are connected to it

Product Multi-Domain Security Management, SmartEvent / Eventia Analyzer

Version R80.40 (EOS), R81 (EOS), R81.10 (EOS), R81.20, R82, R82.10

OS Gaia

Last Modified 2025-04-11

Symptoms

  opsec_new_auth_conn_to_server: conn from <client IP> to entity lea_server (0x....) failed (0) No SIC error message
  lea_server_session_start: too many session established already: 10. session will be rejected for this request.

Cause

FWD daemon might be busy with both writing the information to log file and forwarding this information to SmartEvent/SmartReporter or any other 3rd party LEA client (such as "Arcsight") via LEA session.

Each session requires high usage of memory. Therefore, multiple sessions cause FWD to run out of memory.

Solution

Follow these steps:

  1. Go to the context of relevant Domain Management Server / Domain Log Server: [Expert@HostName:0]# mdsenv <IP address of Name of Domain Management / Log Server>
  2. Stop the relevant Domain Management Server / Domain Log Server: [Expert@HostName:0]# mdsstop_customer <IP address of Name of Domain Management / Log Server>
  3. Spawn LEA sessions to separate process to run on different CPU cores: [Expert@HostName:0]# $CPDIR/bin/cpprod_util CPPROD_SetValue FW1//6.0 Spawn_LEA 4 1 1
  4. Start the relevant Domain Management Server / Domain Log Server: [Expert@HostName:0]# mdsstart_customer <IP address of Name of Domain Management / Log Server>
  5. After restarting a Domain Log Server, it is recommended to fetch the logs from the relevant Security Gateways.

In SmartView Tracker, go to the Tools menu - click on the Remote Files Management - select the relevant Security Gateway - click on the Get File List... button.

Notes:

[Expert@HostName:0]# grep Spawn_LEA $CPDIR/registry/HKLM_registry.data

Article Properties

Access Level General

Status Approved

Date Created 2013-01-14

Last Modified 2025-04-11